It's alive! But wont turn off

The 1UZFE EGR Delete Kit is available for sale here.

BossEng

New Member
Messages
9
Location
Isle of Man
Well, I have my RXV8 running, but the only issue I have now is, it wont shut off when i turn the key off,

when doing a " dry " run, ie. turning the ignition on, M-Rel turns all the necessary relays on, then when i turn the ignition off, M-Rel turns off as do the relays it controls,

now, when I run the engine, fires up fine, but I when I turn the key off, the engine continues to run and M-Rel stays live, therefore keeping the engine running,

its obivously some sort of wiring error by myself, but I just cant fathom it out, its proving difficult to trace because i cant replicate the fault without running the engine,

its a 40x40x40 ECU, M-rel is controlling EGI relays ( one for injectors, one for coil packs ) and the fuel pump ( A bit naughty I know, but it'll do for now )

IGSW is ignition switch ( which turns off when key is turned off )

Constant live has constant live

NSW and start signal are joined together

and it all works as it shoulds until you fire the engine up!!

thoughts or suggestions?

Cheers
Ross
 
Last edited:

Darby

New Member
Messages
13
Location
Christchurch New Zealand
My thought is that it’s getting power from the alternator and that’s what is keeping the relay live. I would disconnect the alternator and try running it (that’s if you are happy to do so) and see if that solves your problem if it does it means that the problem it that side of it.
 

BossEng

New Member
Messages
9
Location
Isle of Man
The alternator isnt connected as of yet,

It's ok, I intend to use IGSW to switch the ignition relay, found a few threads about people having issues with M-Rel,
 
Top