UZFE into a Ford

PARTS FOR SALE: Limited availability on EGR Delete Kits, Torque Converters and Supercharger Brackets. Email for info: [email protected]

Jan Venter

New Member
Messages
51
Location
Hankey, Eastern Cape, South Africa
The ford im using is similar to the old Ford Cortina big 6 but a 92 model.Here in sa called aFord Sierra XR6. the engine bay is obout the same as a Capri, measuring it show a very tiht fit but possible. the Ford engine mountings fit nicely onto the engine brsckets, unfotunately narrowing the mounting points by about 1 ins or 20 cm. First task is to replace the waterpump and cambelt. my biggest problem is still the electronics, so i am going to need a lot of help. Jan Venter SA
 

@ndy

New Member
Messages
18
Location
Potchefstroom South Africa
Hi Jan

How is this going ? I am doing a 1UZ into a mk2 escort, not that difficult the space is tight but it fits nicely into the engine bay with minimal mods, what managment where you planing on using? I am using the Spitronics lexus kit and it looks easy enough.

Regards

@ndy
 

Jan Venter

New Member
Messages
51
Location
Hankey, Eastern Cape, South Africa
@ndy

My engine ran a conrod on first startup, so my project came to a sudden stop. I am getting another engine at the end of jul, meantime i used the time to work out some problems with space. i used the old block as a dummy to measure the space. Problem areas is the master cylinder and booster, the powersteering ravk and the propshaft that is about 6 to 8 cm to short.A friend modified the sump, and i moved the master cylinder and booster to the bat compartment, replacing them with a simpel mast cyl and slave, then moved the battery foward in thr left wheel whel, hoping i can attach some fotos to this thread, hope you guys ealise that i am not a mechanic and on the far wrong side of 50 cheers, jan
 

@ndy

New Member
Messages
18
Location
Potchefstroom South Africa
My engine ran a conrod on first startup, so my project came to a sudden stop. I am getting another engine at the end of jul, meantime i used the time to work out some problems with space. i used the old block as a dummy to measure the space. Problem areas is the master cylinder and booster, the powersteering ravk and the propshaft that is about 6 to 8 cm to short.A friend modified the sump, and i moved the master cylinder and booster to the bat compartment, replacing them with a simpel mast cyl and slave, then moved the battery foward in thr left wheel whel, hoping i can attach some fotos to this thread, hope you guys ealise that i am not a mechanic and on the far wrong side of 50 cheers, jan
Sounds good, sorry to hear about running the conrond, i am almost done with mine, still need to buy a new dizzy rotor as my rightbank one is cracked and i need to buy new boughi cords the no 8 one on mines pin came out and i need a thermostat housing as well.

Good luck with the rest of you build i hope for all the best.
 

samsdad

Member
Messages
561
Location
Perth WA
We used to get a few of the Cologne V6 powered XR4i Ghias come thru the Ford dealership that I worked for in the early '90s in NZ. Absolutely beautiful cars yet a tad temperamental (Lucas electrics), stuck to the road like the proverbial "poo to a blanket" and went like the wind. Always thought that they'd be the "Bees knees" with a nice warm 1UZ in one and I'm pretty sure that around here somewhere is a build thread of one that got done in Norway of all places
 

Bushwhacker

Member
Messages
521
Location
Wales, G.B.
We used to get a few of the Cologne V6 powered XR4i Ghias come thru the Ford dealership that I worked for in the early '90s in NZ. Absolutely beautiful cars yet a tad temperamental (Lucas electrics), stuck to the road like the proverbial "poo to a blanket" and went like the wind.

Hell yeah!:)
This is mine.........


Sold it in 2001.:confused:
 

samsdad

Member
Messages
561
Location
Perth WA
Same thing but 5 door. I seem to remember that the Factory Blaupunkt sound system made it sound like you were in a concert hall no matter if you wanted to play Brahms or Metallica. At the same time Ford Aus also bought the V8 back in with the Fairmont Ghia. Those things were "Sex on wheels", Leather Recaro interior, BBS alloys, Brembo brakes, Borg Warner T5 gearbox, Available in any colour you liked so long as it was either "British racing green" or "Model T black" or "Red". Apparently in NZ we didn't like V8s yet couldn't get enough of them. To quote a beer advertising slogan and the beer is called Tui "Yeah right". Most ended up wrapt around a lamp post or in a ditch
 

Jan Venter

New Member
Messages
51
Location
Hankey, Eastern Cape, South Africa
1UZFE into a Ford

I am certain that my conrod problem was caused by using Quickstart to start a difficult engine, any comments? My new (other) engine is now in and the lengthening of the propshaft done by a professional for R 250. The same problem as witfh the previous engine, i cant get it started. I've shorted the injectors gives me a drop of .5 bar at each tap, so the injectors are ok, i have my fault light running but no codes. Is it possible that i have my plugwires wrong. I know the firing order but am not sure how to read from the dizzys, any help wil be appreciated. Thank You

Jan Venter
 

Jan Venter

New Member
Messages
51
Location
Hankey, Eastern Cape, South Africa
Broken Conrod

My conrod problem was caused by excess fuel delivery causing a static lock.

My engine starting problem was incorrect plug wiring causing misfiring. Nothing wrong with the wires the damn things were incorrectly connected i never expected this and it caused me a lot of worry. Jan Venter
 

Attachments

Jan Venter

New Member
Messages
51
Location
Hankey, Eastern Cape, South Africa
UZFE into a Ford

My engine is in and will start first time every time. had a problem with the spitronics harnass as there was a loose connection, i solved this by buying a new harnes and problem solved. There is still issues icw heat klimbin to fast but this will be resolved in quick time. Jan Venter
 

Jan Venter

New Member
Messages
51
Location
Hankey, Eastern Cape, South Africa
I built a complete exhaust system starting at the manifold flange with 63 mm going to two triangular mufflers coming together into a 76 mm single pipe exit in standard position. Connecting my speedo is now the problem.
 
Last edited:
Top