Single T70 Sc400 5spd

JustenGT8

New Member
Nice....and LOL my car comes up as the next vid :) 5th Gen Celica etc, from way back in 05 when it was first completed.
 

CarlosR347

New Member
i was shocked on how quick it built boost, on the stock plastic intake theres a 1/2inch hole and as soon as i rev it it goes from suck my finger to blowing my hand away! in like no time!:eek:
 

XR8tt

Moderator
Yea free reving turbo's don't actually make boost..
You hear it when throttle is closed tho...Through BOV...
Add some "load" and it'll boost real quick...
 

CarlosR347

New Member
Yea free reving turbo's don't actually make boost..
You hear it when throttle is closed tho...Through BOV...
Add some "load" and it'll boost real quick...

Yea the BOV sounds sick hehe.. and Im having clutch bleeding problems.. its like theres an air bubble in there ive heard of people bleeding these clutches by simply pushing the slave cyl back by hand in other words i gotta put apart the tranny from 1uz, empty the slave and few times and have it fill back up with just fluid from the resivoir.. what a pain.. i guess thats why chevy uses the quick disconnect check valve i replaced lol.. :eek:.. but yea once thats done it should be ready to go.. btw guys it idles very unstable like hondas do when the idle control valve goes bad.. and it runs lean.. to the point were i had to up the fuel with the NEO for the engine to stay on what would you suggest might be the issue?
 

CarlosR347

New Member
ohh! and it idles at 570-600rpm! .. do you think it might be a malfunctioning idle speed valve or my throttle body needs to be adjusted?
 

CarlosR347

New Member
well guys i got to drive the car a couple days ago and all the gears went in smooth! it felt like the tranny came stock.. i drove it up to 50 mph and felt no vibrations or anything.. downshifting was also flawless.. i have to replace the turbo return line it broke a huge leak.. and put smoke everywhere lol.. anyways yea it spools very fast, i have to drain the 3 yr old fuel and clean flush the system.. maybe some seafoam??
 
Last edited by a moderator:

CarlosR347

New Member
I need help!!!

http://www.youtube.com/watch?v=Yr4K99XtQgw

Hey guys after that vid i drove home i parked it and the next morning it had no spark!:eek:..
wtf could be happening? I checked the Crank PS and replaced it with another one I had, I don't think both coils would go bad at least one side would fire I mean it doesn't even fire.. I wanna know how to test if the ECU is bad ??
I was told if the CEL comes on its good well it does and when i bridge TE1-E1 i get codes 24 and 12.. one was the IAT so i unplugged the MAF thinking it may remove the issue, still nothing.. I'm running out of ideas here.. I'm going to inspect the rotors today.. oh and what about the igniters how do i check if those are good, ANY HELP IS GREATLY APPRECIATED!!!!!
 
Last edited by a moderator:

CarlosR347

New Member
Its been FOREVER!! I installed Cometic MLS and lextreme 10mm ARP studs and i finally got it running on 8psi at the moment we took it out to street tune it =) this was a 1st and 2nd gear pull i think it has the stock exhaust from the middle back all you can hear is the engine!! it whistles nice too i love hearing it spool.. we took it on the highway and raped a G35 that same night lol.. i need to open up the exhaust cause its running a bit hot like halfway to 3/4 i think because the stock system is causing back pressure on the turbo and that i need to vent my engine bay some how im thinking about adding a scoop under the engine to scoop up cold air and a flap near the rear of the engine like on aircraft they use Cowl flaps which pretty much produce like a venturi effect between the bottom of the car and the pavement creating a lower pressure and extracting the hot air... any comments?

http://www.youtube.com/embed/dkobgHsoQ7g

 

XR8tt

Moderator
Excessive heat is a sign of a little too rich and retarded timing.. Especially if pipes are glowing on light cruise..
Ceramic coating hot parts and some carefully placed heat shields helps big time..
An old stainless steel saucepan cut and drilled just right makes a VERY good heat shield around turbine housing.. Google pan heat shield..
http://www.supraforums.com/forum/showthread.php?326366-DIY-Turbo-Heat-Shield-write-up-with-pics.
If want to go one step further ?? There's some alloy heat shield out there which can be pop riveted using s/ steel rivets to hold this alloy / fibre glass on the inside of pot shield.. I don't like turbo dipper covers much!!
They hold too much heat in...
HTH...
 
Last edited:

cribbj

"Supra" Moderator
Staff member
Carlos, so what happened to the car back in October that it had no spark? Bad connection somewhere?
 
Top