HELP NEEDED - 1uzfe vvti - probably wiring problem

Kyle Krillx

New Member
HELPPPPPPPPPPPPPPPPP
Ok, so i made a dumb move and challenged myself to build a car in 1 week, putting a Lexus 1uz onto a w58 into a Mk3 Supra,
but I hit a major roadblock... My engine won't run, it'll crank but nothing more. I've been trying to get my engine to run for the past three days, literally have been working on it for 10 hours each day at least, and have somehow gotten nowhere.

What I have -
-I have the 1UZFE VVTi engine (I believe it came out of a 99-00 Lexus SC400) just the motor, no transmission
-I have the ECU (that I believe is the original stock ECU)
-I have the stock wiring engine wiring loom which came pre-plugged in and all that


My engine



My engine again



Wiring loom and ECU



ECU




What I've done -
-Connected the EB2 (2) wire which is black with red stripe (I believe is ignition 1) directly to the positive to the battery
-Connected the EB2 (3) wire which is also black with red stripe but physically larger(I believe the starter power wire) directly to the positive on the battery
-Connected the IJ2 (11) wire which is black with orange stripe with silver dots directly to the positive on the battery
-Connected the IJ2 (11) wire which is yellow with black stripe directly to the positive on the battery
-Put in new SAE 5W-30 oil, there is an oil leak but it has enough oil to run


IJ2(11)



top left EB2(3), middle bottom EB2(2), top right EB1(4)



What I've tried -
-Used starter fluid spray directly in the air intake, did NOT work
-I plugged in a blade fuse in the power and ground wire(i think) of the transmission plug to try to trick it into thinking it was in park because maybe the ECU wouldn't let it run, did NOT work
-Bought and connected a MAF sensor (from a junkyard Toyota) and plugged it right in without an air intake, i was told it would run without one but got one anyways because i also heard it the ECU won't let it run without MAF input, did NOT work
-Looped (plug a wire in power running to ground) O2 sensors near transmission plug, tested with and without, did NOT work
-Cleaned spark plugs for healthy ground
-Tested power to ECU, it was receiving power (12.6 Volts approx)
-Probably a lot more but writing this from my crappy memory now

MAF sensor plugged into MY engine



Transmission plug with blade fuse


Final words -
- I believe the ECU is not sending signals to the spark plugs, therefore there's no combustion, I don't know why
- I have spent hours and hours and hours on lots of forums trying to figure this out myself, obviously couldn't solve the problem
- I may just be missing something important, honestly I don't know now
- I tried to be as descriptive as can be because I know that helps others diagnose the problem
- If you have a question just ask, and I'll answer it to the best of my capabilities or I will honestly tell you I don't know
- PLEASE TEXT OR CALL ME AT 512-720-1166 IF YOU THINK YOU CAN HELP, OR HAVE A SUGGESTION

More engine photos -







 

George_R

Member
1 read trouble codes
you're probably getting immobilizer error which will not allow the engine to start
2 you will not get stock power unless the a/t is properly simulated
bridging inhibitor switch to neutral position will make ECU use its power limited fuel/vvti/ignition maps designed for P,N mode
 

gloverman

Well-Known Member
I dropped a vvti 1uz into a mk3 supra yesterday. I'd say your ecu is immobilized too. I've wired more 1uz vvti this year than I can remember and have about 5 here to do atm. Very few don't have the immo. Connecting a scanner will confirm and is the easiest way to diagnose these engines.
 

Kyle Krillx

New Member
I've looked into the immobiliser problem and from what I understand is that most engines will still start but the ecu will shut it off a few seconds after if it's immobilized. Is this different for 1uzfe vvti ? And how can I fix it? Do I have to buy a custom bypass or what are the options to solve it?
 

gloverman

Well-Known Member
The VVti will generally almost fire on the initial crank then do absolutely nothing from there until the ECU is reset then it repeats. Youtube CartuneNZ and you will find an option to sort. Cheers
 
Top