Remedial wiring (99' GS400)

Discussion in 'Electrical & Electronics (Interior)' started by Spinnetti, Jan 31, 2017.

  1. Spinnetti

    Spinnetti New Member

    Joined:
    Jul 29, 2009
    Messages:
    305
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    IT
    Location:
    KY
    Did a motor swap in my 91' LS from a 99' GS, including complete engine, trans and most of the wiring harness, including the cluster, Immo, key, ECU etc.

    So I plugged everything in I could, and dash lights up, but not sure:
    1. What are the symptoms of the Immo saying "no"? - When I turn the key, the Starter doesn't kick, and the fuel pump never kicks on is that related?
    2. Is there maybe a shifter switch I'm missing that would prevent the pump and starter going? On my other cars, when you put the ignition on, the fuel pump runs, but this doesn't happen (no voltage). Pretty sure the wiring and relays are right to the pump, so I suspect the ECU is saying no for some reason.

    There's so much wiring I'm a bit overwhelmed.. the complete engine & trans harness and main fuse box is all there and untouched. Ug. I so want somebody to wire this thing from "cold". If I can get it to run, I can figure out all the other circuits.

    https://www.amazon.com/photos/share/d4Yntjv47IbsvqBW1tRuQR8iYMUk3k3qkrwEUOTgUgu
     
  2. Spinnetti

    Spinnetti New Member

    Joined:
    Jul 29, 2009
    Messages:
    305
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    IT
    Location:
    KY
  3. George_R

    George_R Member

    Joined:
    Sep 13, 2010
    Messages:
    812
    Likes Received:
    1
    Trophy Points:
    18
    Gender:
    Male
    Occupation:
    DSP engineer
    Location:
    Russia, Moscow
    Home Page:
    Connect LED to IMLD pin of ecu
    It should blink when ignition is off, and stop blinking right after you turn the key
    If it keeps on blinking, immo says no
     
  4. Spinnetti

    Spinnetti New Member

    Joined:
    Jul 29, 2009
    Messages:
    305
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    IT
    Location:
    KY
    Thanks George... Does it require trans in park and or foot on brake? If so, I'll need to figure how to fake the park sw.
     
  5. George_R

    George_R Member

    Joined:
    Sep 13, 2010
    Messages:
    812
    Likes Received:
    1
    Trophy Points:
    18
    Gender:
    Male
    Occupation:
    DSP engineer
    Location:
    Russia, Moscow
    Home Page:
    Yes it does but ECU will happily start without them wired properly (ECU would even start the engine if you have half of coils,injectors connected and only crank angle sensor signal available)
     
  6. Spinnetti

    Spinnetti New Member

    Joined:
    Jul 29, 2009
    Messages:
    305
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    IT
    Location:
    KY
    so if I find the right pins, I can short them at the ecu to ignore the trans switch at least? Basically the fuel pump and starter won't run and not yet sure why.
     
  7. George_R

    George_R Member

    Joined:
    Sep 13, 2010
    Messages:
    812
    Likes Received:
    1
    Trophy Points:
    18
    Gender:
    Male
    Occupation:
    DSP engineer
    Location:
    Russia, Moscow
    Home Page:
    You don't need to short anything
    ECU doesn't look at trans switch for starting
     

Share This Page