1993 Lexus LS400 kills fuel pumps every month

Discussion in 'Diagnostic & Repair Tech' started by Confused_Screaming, Jul 5, 2018.

  1. Confused_Screaming

    Confused_Screaming New Member

    Joined:
    Jul 5, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    What the title says. I'm about to install the third fuel pump in this thing. I took out the one that came with it (Toyota branded) because it felt a bit weak, but otherwise had no real issues. The replacement, a Spectra fuel pump with kit and strainer, lasted about three months before finally becoming so weak that I was losing speed from 40mph on flat ground. The new pump, which is the same brand and kit as the old one, is dying as well. It started skipping on acceleration last night. Is this an issue with Spectra pumps, or something with the car?
     
  2. gloverman

    gloverman Well-Known Member

    Joined:
    Oct 15, 2004
    Messages:
    2,686
    Likes Received:
    54
    Trophy Points:
    48
    Occupation:
    mechanic
    Location:
    Hamilton. New Zealand
    I'd be fitting a different brand of pump myself. Personally my first choice is Factory branded Nippon denso. This is my prefer choice in pumps for all my conversions and the kit I stock fits most factory applications too.
     
  3. Confused_Screaming

    Confused_Screaming New Member

    Joined:
    Jul 5, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Bought the Denso one off of RockAuto. The previous Spectra kits were the best Autozone had, and I only bought the same one the second time around because I had work the next day and needed my car to actually go places. Hopefully the new pump doesn't immediately crap out, and hopefully the current one lasts until wednesday - it's dying pretty quick.
     

Share This Page