Jzs157 1uz ecu (89661-3a310, non-immobilized) - pictures and info

Discussion in 'Fuel, Ignition, Air, & Tuning (FIAT) (Members On' started by black_LS, Feb 12, 2017.

  1. black_LS

    black_LS New Member

    Joined:
    Jun 25, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Occupation:
    -
    Location:
    Toronto
    *Title should read UZS157

    Hi all,

    I got my hands on a Crown Majesta non-immobilized ECU. Luckily, it had the three rightmost plugs still in it, so I'm able to see which wires were connected from factory as well as the wire colours.

    Click on the images below for full size.

    [​IMG]


    [​IMG]



    [​IMG]



    [​IMG]



    [​IMG]



    [​IMG]


    At first, I thought that these plugs might have been out of a different model, but then I found these pictures that confirmed they are correct.

    [​IMG]


    [​IMG]

    I read that this ECU has a similar (if not same) pinout as the Celsior/LS400, however after looking at it, some of the wires are in different places. For now I'm focusing on the rightmost plug (where immo wires would have been).

    This motor did not have a hydraulic fan, and the ECU does not have an immobilizer or MPX bus, so many of the wires are gone, but it still seems a bit odd (and minimal). Below is what you would expect to see on a Celsior.

    If I use the Celsior pinout, then the wires should be as follows:

    [​IMG]

    Present:

    1 - green - D
    10 - red - ??
    14 - black/brown - STI-
    16 - blue/white - L
    25 - green/orage - 4
    26 - violet/green - RL

    Missing:

    3 - IMLD
    4 - EOM
    5 - HP
    6 - TH-
    7 - TH+
    8 - SOL-
    9 - SOL+
    11 - MPX1
    12 - CCV
    17 - TXCT
    18 - CODE
    19 - RXCK
    20 - KSW
    21 - LCK1
    22 - TAM
    23 - PRE
    24 - MPX2

    1. What is the red #10 wire?
    2. Does it make sense that this ECU is missing KSW due to no immobilizer?
    3. What about the HP, LCK1, PRE, and TAM pins for the A/C?
     
    Last edited: Feb 24, 2017
  2. George_R

    George_R Member

    Joined:
    Sep 13, 2010
    Messages:
    822
    Likes Received:
    2
    Trophy Points:
    18
    Gender:
    Male
    Occupation:
    DSP engineer
    Location:
    Russia, Moscow
    Home Page:
    These a/c pins would not make sense without MPX bus
    Looks like there must be AC1, AC2 pins somewhere, like it was with older ECUs
    As well as ELS1,ELS2 pins

    You can try using Soarer diagrams. SC400 that had 4.0 vvti engine had no MPX bus either
     

Share This Page