Search results

  1. I

    Adaptronic and TV8 R154 conversion

    I don't check Lextreme as much, but email is fine [email protected]
  2. I

    Adaptronic and TV8 R154 conversion

    As title states, I have an adaptronic E420c with a PNP harness that KC95SC400 made awhile back. I also have a pipe with the AIT sensor welded into, along with a map sensor. I'd like to get 600 shipped for this. I also have a Toyotav8.com R154 swap kit. I would like to get 700...
  3. I

    1uz Missing problem when in gear

    Try unplugging it, if you can unplug it and it runs well then you have an issue with the AFM. It could also be an ECU issue. The older toyota ECU's are known for leaky caps which will cause some major weird problems
  4. I

    Procharged 1992 SC400 "Fish bracket setup"

    Not quite, mechanically it is done. I have my injectors, map and iat sensors here. I was waiting on my usb->serial from Jaycar. It came from Australia today. I've gotta finish up my Z (the reflashed ecu and injectors made it!), once my S30 is on the road, I'll put the SC down to finally...
  5. I

    WTS Adaptronic E420c

    No problem, if you end up going with the adaptronic hit me up and I can help you out with wiring it up with some of the notes that I got from members here.
  6. I

    Procharged 1992 SC400 "Fish bracket setup"

    I believed she got parted out. Pulleys are easy, same as the belt. If you're talking about the blower for the pulley, then whatever blower you get, the manufacturer will be able to get you the right pulley size. They'll need to know: boost, crank pulley diameter, and how many ribs, and they...
  7. I

    WTS Adaptronic E420c

    I've decided to keep it for myself. It's a very good system with a good bit of support (from Aussie land). It's pretty easy to wire up, a little daunting. If my car ran well with the stock EMS I would have piggybacked it, but the blower and the stock ecu aren't being friendly, so one of 'em...
  8. I

    Terrible running SC'ed SC400

    I don't think so to be honest, since when I'm driving it's not at boost. Just cruising. I'm going to find some way to move the KMV sensor I think that's my biggest problem. I have an Adaptronic E420c (I think) I just need to figure it out how to wire it up though.
  9. I

    Terrible running SC'ed SC400

    Changed all timing sensors and no dice. So I did make some progress, I was running without an air filter because it sat in the front bumper with nowhere else to go, I moved the KMV sensor as best as I could where it sat outside of the engine for temporary testing. I noticed that my air filter...
  10. I

    Rising Rate Fuel Pressure Regulator

    I would say that Justen is right, however, 5-7 psi from what? Are you running a blower or a turbo, and how big? 5-7 psi from a T25 versus 5-7 psi on a HX40 are going to be vastly different. Fortunately enough the UZ runs rather rich from the factory, so as Justen stated, most can get away...
  11. I

    wideband sensor bung location for turbocharged v8 gen 1 tundra

    I've actually wondered about where on a rear mounted setup. On my car it's currently in the Y-pipe, but I'm SC'ed and definitely no rear mounted. I would assume it would just go into the downpipe POST turbo just as any normally mounted turbo
  12. I

    Thieves apparently dislike Toyota Prius, as Prius theft rates very low

    Agreed with gloverman. However, the only thing is making a new car keeps jobs.
  13. I

    Terrible running SC'ed SC400

    Replaced the two cams sensors, no change. Checked for a vacuum leak, no leaks. Swapped in a new coil and moved to both sides, no change. Going to replace the crank sensor in a minute. And trying to find another TPS at the moment. After that, I'm going to add a rag plus a lighter to finish...
  14. I

    Terrible running SC'ed SC400

    Nope, tried THREE different KMV sensors. Tested them on a pal's running SC4
  15. I

    Terrible running SC'ed SC400

    Oh, I noticed the car runs a bit better when I first start it up in the morning (doesn't buck or hesitates as much), but I replaced the CTS and that made no difference.
  16. I

    Terrible running SC'ed SC400

    Okay guys, I haven't driven my SC for quite some time since I was working on another project. So here are the specs: 92 SC400, Fish Bracket Vortech V1 Stock ECU, injectors removed EGR W58 Pretty much after the blower the car has ran like straight crap. The car bucks and misses...
  17. I

    WTS Adaptronic E420c

    yup, KC95SC400 and a few others have used it for boost tuning
  18. I

    Weird rich condition ONLY at 2K?

    LoL FMU = Fuel Management Unit AKA Rising Rate Fuel Pressure Regulator AKA RRFPR TPS = Throttle Position Sensor OBD I = On Board Diagnostic I AFR = Air Fuel Ratio SAFC = Super Air Flow Converter (Aftermarket piggy back ecu controller) KMV = Karmen Vortex Sensor
Top