Latest activity

  • George_R
    George_R reacted to ChopsLS430's post in the thread OEM 3UZ ECU TUNE/FLASH with Like Like.
    Funny you mentioned that as I just stumbled across those videos and watched all four episodes of the LS/M5. At the end of Dave's last...
  • S
    Schnitzel26 replied to the thread 1UZ-FE problems in a Cobra..
    Thanks so much for that, I tested it once again per your suggestion, and nothing worked. We are convinced the ECU is U/S so now on the...
  • ChopsLS430
    ChopsLS430 replied to the thread OEM 3UZ ECU TUNE/FLASH.
    Funny you mentioned that as I just stumbled across those videos and watched all four episodes of the LS/M5. At the end of Dave's last...
  • ChopsLS430
    ChopsLS430 reacted to seagate9's post in the thread OEM 3UZ ECU TUNE/FLASH with Like Like.
    pretty cool to know, there is this big youtube channel called speed academy with almost 400k subscribers that is being sponsored to...
  • Zuffen
    Zuffen replied to the thread Results of mods on SC400.
    Jibby hasn't been on here for a few years. No maybe a lot of years. 50Hp is a lot to get out of cams. These engines respond better to...
  • A
    Just to follow up on this, the bhp seals are totally different to the correct toyota seals. Bhp are solid whilst toyota seals are more...
  • R
    rajputaman04 replied to the thread Results of mods on SC400.
    i donno, im at 14.7 with 220rwhp, and stock 92 is maybe at 190? 50hp should yeild better results than a flat 15 i would think?
  • 3
    361UZ replied to the thread 1UZ-FE problems in a Cobra..
    " Obviously, if I can get the checking system to work, it will throw quite a few codes as a lot of things haven't been connected. " But...
  • S
    Schnitzel26 replied to the thread 1UZ-FE problems in a Cobra..
    Hi again. This car has been sitting at the mechanic for a year now! The mechanic (Wayne) tells me EVERY sensor has been either tested...
  • 3
    361UZ replied to the thread 1UZ-FE problems in a Cobra..
    Interesting progress. An ECU WITH a working checking system would be a must, even if the problem with the car is something else. Its the...
  • S
    Schnitzel26 replied to the thread 1UZ-FE problems in a Cobra..
    Thanks again, guys. As an electronics tech, and not an auto electrician, I have replaced ALL the caps in the ECU, and the fusible...
  • 3
    361UZ replied to the thread 1UZ-FE problems in a Cobra..
    See the video. The light should be ON with ignition and go out when the engine starts, unless you have a fault that has set an error...
  • S
    I have been having issues setting base timing on my turboed 93 1UZ non VVTi on 14lbs of boost. Before I rebuilt the engine my timing...
  • G
    gloverman replied to the thread 1UZ-FE problems in a Cobra..
    In the video I diagnosed a faulty ecu that didnt have a CEL output. No CEL is a fail for the ECU. I did a video on ECUs as well. I...
  • S
    Schnitzel26 replied to the thread 1UZ-FE problems in a Cobra..
    Thanks for the reply. I understand your reluctance to sell second hand. I always told my customers that I can do a cheaper repair with...
Top