1UZ VVTi swap: ODB-II Connection & Throttle???

arpphoto

New Member
Hello.

I completed a JDM 1UZ VVTi swap into a 94' SC400 about 4 months ago. The engine came from a 2000 ~ 2002 Majesta and the 5 speed gearbox is a Nissan. I am using the JDM ECU that came with the engine and a ATEMU to simulate the AT.

The vehicle is a track car. Chassis was completely striped down and built back up with a roll cage and the bare minimum required to run on a track.

The engine fires right up and I have taken it around the block (20 mph) a few times without any noticeable issues... However, I do not have a code checker at the moment so it could have a 100 codes for all we know....

Have a few things I need help with:

#1 - I would like to use a ODB II app or a standalone unit as my gauges... I am not sure winch wires are needed to run a ODB II unit... From the JDM Majesta diagram I see that the ODB II plug uses WFSE, TC, TAC, and SIL along with GROUND and 12V. Which ones do I need and which pins do they goto on a ODB II plug?

#2 - The throttle only seems to open about 25%... From what I understand the throttle system on the VVTi motors operate on a hybrid system: the mechanical part only opens so much and the rest is via electric motor. How can I test it to see if the throttle system is working properly or not?

#3 - What ODB II code reader and gauge unit does everyone recommend? I have a cheap hard wired standalone unit in my Ford pickup but it has a delay of about 1 ~ 2 seconds on the RPM and O2 readout and a very small screen.

Thanks

Adam
 

Attachments

gloverman

Well-Known Member
Only need sil to pin 7, grounds 4 and 5 and voltage to 16.

Throttle should open all the way with key on, engine off

I use a obd2 adaptor and my smartphone for comms
 

arpphoto

New Member
Only need sil to pin 7, grounds 4 and 5 and voltage to 16.

Throttle should open all the way with key on, engine off

I use a obd2 adaptor and my smartphone for comms
Thank you Gloverman!

Which ODB2 adapter did you use?

My throttle does not open all the way with key on engine off... besides checking continuity on TPS, APPS and TCM wires, anything else or common issues I should look for before replacing them?

Thanks!

Adam
 

gloverman

Well-Known Member
Did I use? Do I use. Im wiring vvti all the time and prefer an adapter I get over here on trade me. Triple H branded but all cheap Chinese copies.

Generally if you have just the ecu powered up with just the throttle wiring attached they work fine. Often its something else causing the issue. Like converting it to manual incorrectly. Ive done a couple of YouTube videos on some basic mechanical and a bit of electrical but not much on fault finding dbw yet.
 

arpphoto

New Member
Did I use? Do I use. Im wiring vvti all the time and prefer an adapter I get over here on trade me. Triple H branded but all cheap Chinese copies.

Generally if you have just the ecu powered up with just the throttle wiring attached they work fine. Often its something else causing the issue. Like converting it to manual incorrectly. Ive done a couple of YouTube videos on some basic mechanical and a bit of electrical but not much on fault finding dbw yet.
Ok thanks

Adam
 
Top