Search results

  1. S

    1UZ UCF20 runs horribly rich

    Fixed the MAF issue, it didn't have any 12v. That fixed it running too rough, and now it runs too lean. Did some vac tidy up today, no leaks, started doing the oxygen sensor wiring and just... Gah. I am just getting a custom ecu come the spring, I give up. I've had this car for 6 years and I...
  2. S

    1UZ UCF20 runs horribly rich

    Thanks Yeah I opened it and had a look a while ago, didn't see anything obvious but that doesn't rule out something just failing internally. Didn't go for a recapped ECU because I think I'll just get an aftermarket ECU at this rate, but don't have the money just yet. Also the problem is I know...
  3. S

    1UZ UCF20 runs horribly rich

    Sounds reasonable. I think if I had a better guide than the 1uz doc by Nigel Wade and various forums I could fix a lot of issues much quicker. Or if I went custom but really don't need that at the moment. I'll shoot you an email
  4. S

    1UZ UCF20 runs horribly rich

    Still having issues with this, turns out it wasn't running out of fuel, it just runs super lean and wants to die unless I rev it a bit. Then it injects fuel as normal which rules out a lot of stuff. Any return to idle will eventually lean out and cause a stall after about 10 seconds. I guess...
  5. S

    1UZ UCF20 runs horribly rich

    I'd absolutely love that pinout if you have it please!! How much do you sell your instructions for? Or even just that pinout, because I have the rest. Also, I managed to fix the smoke issue. Whilst I didnt have a pinout, I did have my multimeter so I started probing. I probed a red/black wire...
  6. S

    1UZ UCF20 runs horribly rich

    So I watched some more of that channel and found something interesting. I have a further theory regarding the AFM, but I am struggling to find/read diagrams to prove or disprove it. The white plug that is on the engine harness that doesnt plug into the ECU, (Chassis plug maybe?) could be a...
  7. S

    1UZ UCF20 runs horribly rich

    As for the lambda sensors, is it acceptable to just tie the same narrowband output to both the OXL1 and OXR1? Or should I go for all four, front and back? Not sure why its still giving front sensor errors, I guess its not seeing the heater resistance?
  8. S

    1UZ UCF20 runs horribly rich

    I'll check out the channel for more info. I've seen a few vids but there is so much info on there! Yeah thats what I'm working down, but I'm a bit stuck on my MAF diagnosis as to where pin 1 and 5 connect to in the ECU for a continuity test. I think I'm getting confused over earlier wiring...
  9. S

    1UZ UCF20 runs horribly rich

    Hi all, I created an account just to try and solve this problem on my project car swap. I'd really like your thoughts on the issue, but I guess even if noone has any ideas it helps my head to write it all in one place. I've had this issue for probably 2-3 years, and since I'm finishing up...
Top