Won't revs

Discussion in 'Diagnostic & Repair Tech' started by tatthep, Jul 12, 2018.

  1. tatthep

    tatthep New Member

    Joined:
    Feb 28, 2018
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hi, my car won't revs up on N if driving on the road not problem
    What wrong ? (Engine swap)
     
  2. gloverman

    gloverman Well-Known Member

    Joined:
    Oct 15, 2004
    Messages:
    2,610
    Likes Received:
    34
    Trophy Points:
    48
    Occupation:
    mechanic
    Location:
    Hamilton. New Zealand
    Did you connect power to the blue wire on the forth plug?
     
  3. tatthep

    tatthep New Member

    Joined:
    Feb 28, 2018
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Um i dont know tomorow ill check it what wire,pin my ecu 26:16:22:26 pin
     
  4. gloverman

    gloverman Well-Known Member

    Joined:
    Oct 15, 2004
    Messages:
    2,610
    Likes Received:
    34
    Trophy Points:
    48
    Occupation:
    mechanic
    Location:
    Hamilton. New Zealand
    Ok. With that ecu if there is a blue wire in pin 14 of the separate 26 pin plug then earth that blue wire and see if it makes a difference. Otherwise provide some more information. Cheers
     
  5. tatthep

    tatthep New Member

    Joined:
    Feb 28, 2018
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    In the diagram there is no telling with pin 14
     
  6. tatthep

    tatthep New Member

    Joined:
    Feb 28, 2018
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    And my plug have not wire
     
  7. gloverman

    gloverman Well-Known Member

    Joined:
    Oct 15, 2004
    Messages:
    2,610
    Likes Received:
    34
    Trophy Points:
    48
    Occupation:
    mechanic
    Location:
    Hamilton. New Zealand
    I am aware pin 14 is not on any diagrams however I know what it is hence the tip. Have you checked fault codes?
     
  8. tatthep

    tatthep New Member

    Joined:
    Feb 28, 2018
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Um if you mean in normall mode when sw. Key on (IG) check engine will show usual the light is not flashing but if you mean check codes on diagnose con. Te1,e1 is it correct ? It show 47,56 i have read one article about code 47,56 not affect how much I do not know if this may be part of it
     
  9. gloverman

    gloverman Well-Known Member

    Joined:
    Oct 15, 2004
    Messages:
    2,610
    Likes Received:
    34
    Trophy Points:
    48
    Occupation:
    mechanic
    Location:
    Hamilton. New Zealand
    Both 47 and 56 could cause your issue. 56 doesnt effect later ecu but it causes rev issues on your early ecu. Ive outlined how to sort that so not going over that again. Code 47 i would guess either you have got wiring wrong or you have a sensor or maybe ecu fault. I remove trac and wire the ecu as a non traction control unit as per my diagrams. I find it easier to delete system and i think it makes the engine look a bit tidier. I cut the sub tps off, put a fitting into the hole and use as the air supply for the iac. To sort i would be comparing pin voltage charts to readings from your vehicle. Good luck.
     
  10. tatthep

    tatthep New Member

    Joined:
    Feb 28, 2018
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Thankyou what should i do?
     

Share This Page