The Fish

Discussion in 'Forced Induction Tech (Members Only)' started by kc95sc400, Oct 5, 2007.

  1. Lextreme

    Lextreme Just call me "Lex"

    Joined:
    Mar 6, 2003
    Messages:
    12,051
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Professional
    Location:
    City of Halos
    Home Page:
    KC,

    Great to hear that your ride is kicking. Keep up the good work.... More vids... and longer vids please....
     
  2. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    Thanks Lex!

    Keep an eye out, plan to make and post some later today!

    KC
     
  3. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    This is one I should have made a long time ago.

    I tried to show my current IC setup. This is what I'm going to stick with, just need to clean it all up a bit. Once I have the IC and piping cleaned up, I'll clean up the rest of the engine bay.

    Let me know what you guys think.

    http://www.youtube.com/watch?v=3L56h77uO3Q

    Still hope to make a few driving vids later.

    KC
     
  4. Lextreme

    Lextreme Just call me "Lex"

    Joined:
    Mar 6, 2003
    Messages:
    12,051
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Professional
    Location:
    City of Halos
    Home Page:
    KC,

    Its prefect. Idles very nice and the sound is just too good. I am so proud of you and I am proud of myself you. You made me proud!
     
  5. RedPhoenix

    RedPhoenix New Member

    Joined:
    Nov 15, 2006
    Messages:
    512
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Boat
    Location:
    Palm Harbor, FL
    Man I am stoked. Just came out so well! And its stock minus the supercharger motor wise? I love the sound. I cannot wait to actually do mine.

    Good job again, thanks for being the first to post all the info!


    Do have a question. Any reason why the CEL is on?

    Matt
     
  6. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    Thanks Lex. I have lost count of the time and effort I've put into the car, but once I finally get it all cleaned up and tuned, it will be worth it.

    Note - I'd say about 95% of the time put into it was spent figuring out why I couldn't make boost and the many piping setups I've tried. I've probably got about 5 hours into installing the SC itself, which includes taking it off once to add some shims.

    KC
     
  7. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    Thanks.

    Yes, motor wise stock. Only other speed adders are the dragon TQ and the LSD. I'm still waiting on the headers.

    The CEL is on because I have the driver's front 02 sensor out, the wideband is currently in the hole. When I get the headers, I will likely get that fixed. Other than that, no codes.

    KC
     
  8. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    Anyone care to make a RWHP estimate based on the 0-60 time? 5 seconds is 1.5 to 2 seconds faster than stock, which is quite a significant reduction.

    I'm very confident I can get under 5.

    I will eventually have the car dynoed, but it will be a while until I do.

    KC
     
  9. sonoramike

    sonoramike New Member

    Joined:
    Jun 3, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    none
    Location:
    sonora, ca
    a quick down and dirty HP calc shows a 3800lb car with RWD and auto would take 400hp to do a 4.858756556460258 second 0-60 time
     
  10. RedPhoenix

    RedPhoenix New Member

    Joined:
    Nov 15, 2006
    Messages:
    512
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Boat
    Location:
    Palm Harbor, FL
    but its no where near 400hp... id say 300ish.
     
  11. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    I assume the 400hp estimate would be at the flywheel, which would be roughly 320rwhp. I think this is probably in the right neighboorhood.

    The only similar setup I can compare to is the original SC400 fish install which belongs to George on this forum. http://www.lextreme.com/forums/showthread.php?t=5444&highlight=fish

    He made 276rwhp with 5 psi. Main differences between his setup and mine, he is using a bigger blower (v1), but I am blowing in the 8-10 psi range.

    A dyno will be the only way to know for sure of course. Before I go to a dyno, I need to do some tweaking to my IC setup, get my headers and install them, and do some street tuning.

    BTW, I really like my current IC setup, but I have one more thing I need to try. Same pipe path as seen in the video but I want to put straight pipe in place of the IC. I am very curious to see what the temp difference will be between non IC pipe in the engine bay and non IC pipe not in the engine bay.

    Khris
     
  12. lexplay

    lexplay New Member

    Joined:
    Jun 27, 2007
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    hitech (parts suplier)
    Location:
    perth (currambine)
    good to see its worked out ok for u kc. i just bought thermactors supercharger off him and currently am collecting up the rest of the parts to do it. im sure you's will hear more from me when i get closer to puting it on.
     
  13. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    Thanks.

    Very awesome to hear of another fish project in the works (thanks again Lextreme!) and that is one hell of a deal from thermactor.

    On a side note, anyone considering a fish setup with a Vortech should keep an eye out for the V-9's on ebay. They are usually cheap compared to the V1s and the V2s, less demand for them. And depite a few people who thought that the V-9 is too small, and a few people who out right told me it's too small (including Vortech customer servie), I think I've proven that it works, and it works darn well to boot.

    Khris
     
  14. Lextreme

    Lextreme Just call me "Lex"

    Joined:
    Mar 6, 2003
    Messages:
    12,051
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Professional
    Location:
    City of Halos
    Home Page:
    Honestly speaking, the Fish is the most affordable comparing to the rest of the FI system. I am glad u guys take it to the next step. Lexplay... Lets get it on!
     
  15. cribbj

    cribbj "Supra" Moderator

    Joined:
    Jun 10, 2004
    Messages:
    4,593
    Likes Received:
    0
    Trophy Points:
    36
    Occupation:
    petroleum industry
    Location:
    Houston, TX
    KC, I don't know if you're following the ITB thread here: http://www.lextreme.com/forums/showthread.php?t=9322 The last day or so we've been talking about the potential for reducing lag in a centrifugal setup by using ITB's and tweaking the supercharger bypass valve. Might be an interesting read for you, or anyone else running a centrifugal.
     
  16. lexplay

    lexplay New Member

    Joined:
    Jun 27, 2007
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    hitech (parts suplier)
    Location:
    perth (currambine)
    it shouldnt be too long before i start so far i have got
    fish bracket
    bolt kit
    v2 supercharger
    oil t-peice
    2x idler bearings
    rising rate fuel reg
    blow off valve
    au thermo fan

    all the piping and lines i will make up when its on the car. im not going to run a intercooler, its just going to be straight in.

    do you think it will run with just the rising rate fuel reg plus a AEM wideband uego controller to see whats happening?
     
  17. stevechumo

    stevechumo New Member

    Joined:
    Mar 7, 2005
    Messages:
    3,051
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Software analyst
    Location:
    OC, City of Sunshine
    I believe10 psi should give around 400 bhp, but not rwhp. On average and proven of 6 psi, the SC400 will make additional 80-90 hp. 10 psi should yield an additional 150 hp. The SC400 bhp is about 250. However, this depends on how the car is tuned. Rich condition will usually lose power, while just a little leaner condition will make more power.
     
  18. 1uzvl

    1uzvl New Member

    Joined:
    Aug 16, 2005
    Messages:
    348
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Radiator Fitter
    Location:
    Perth Australia
    Lexplay,i would be real keen to eyeball your setup when you get it done if you would like to show it off.Im at the stage of a turbo/supercharger showdown and i think the supercharger setup is winning.My vl is just begging for some boost and a nice vortech supercharger with the straight cut gears is just the mechanical howl to tuffn her up.
     
  19. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    I'm afraid to go to lean, seeing as I'm probably already pushing the limits a little. Running 10ish psi without any fuel mods other than the MAFTPro, and I did also bypass the fuel pump ECU. I may actually un bypass the FPECU, I'm not sure I'm seeing any benefit from it.

    I have the MAFTPro set for 12.5 with boost, it works great. But..when I first go WOT, it hangs around 10-11 to 1 for a second and I can definately feel the loss of power. Haven't figured out how to tune it out yet. I think I may actually have a boost leak somewhere after the MAF, but I haven't been able to find anything.

    KC
     
  20. kc95sc400

    kc95sc400 New Member

    Joined:
    May 27, 2007
    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Toyota Tech
    Location:
    Charlotte, NC
    Awesome. FYI, with my car I was seeing IAT temps of 65-75 above ambient without boost when I had it straight in. From everything I have read, that is fairly low, but it was making my nervous. Otherwise, straight in had the best overall driveability.

    KC
     

Share This Page